高危 | Apache CouchDB权限提升漏洞

  • 作者:
  • 时间:2022-04-28 09:00:36
简介 高危 | Apache CouchDB权限提升漏洞

0x01

漏洞状态

漏洞细节

漏洞POC

漏洞EXP

在野利用

未知

未知

未知

0x02

漏洞描述

Apache CouchDB是美国阿帕奇(Apache)基金会的一个开源的面向文档的数据库管理系统,可以通过 RESTful JavaScript Object Notation (JSON) API 访问。

2022年4月26日,Apache发布安全公告,修复了一个 Apache CouchDB中的远程权限提升漏洞。漏洞编号:CVE-2022-24706,漏洞威胁等级:严重。

Apache CouchDB 权限提升漏洞

Apache CouchDB 权限提升漏洞

漏洞编号

CVE-2022-24706

漏洞类型

权限提升

漏洞等级

严重

公开状态

未知

在野利用

未知

漏洞描述

在3.2.2 版本之前的 Apache CouchDB 中,可以在不进行身份验证的情况下访问不正确的默认安装并获得管理员权限:

1. CouchDB 打开一个随机网络端口,绑定到所有可用的接口以预期集群操作或runtime introspection,称为 "epmd "的实用程序向网络公布了这个随机端口。epmd本身在一个固定的端口上监听。

2. CouchDB包装之前为单节点和集群安装选择了一个默认的"cookie "值,该cookie用于验证Erlang 节点之间的任何通信。

0x03

漏洞等级

严重

0x04

影响版本

Apache CouchDB <3.2.2

0x05

修复建议

厂商已发布补丁修复漏洞,用户请尽快更新至Apache CouchDB 3.2.2及更高版本。下载链接:https://couchdb.apache.org/

CouchDB 3.2.2 及更高版本将拒绝使用以前默认的Erlang cookie值为`monster',升级到此版本的安装将被迫选择不同的值。

此外,所有二进制包都已更新,以绑定`epmd`以及CouchDB分发端口分别为`127.0.0.1`和/或`::1`。

与此同时,请做好资产自查以及预防工作,以免遭受黑客攻击。

0x06

时间轴

2022-04-26

Apache发布安全公告,修复了一个 Apache CouchDB中的远程权限提升漏洞。漏洞编号:CVE-2022-24706,漏洞威胁等级:严重。

2022-04-27

360漏洞云发布安全动态。

关闭